Back to overview
Maintenance

Website Reconstruction

Apr 15 at 07:03pm BST  –  Apr 23 at 05:11pm BST
Affected services
Website

Resolved
Apr 29 at 06:05pm BST

Website Nearly Complete

Updated
Apr 23 at 05:11pm BST

Our Website Is Not Being Reconstructed As Early As We Thought. The Maintenance Will Be Moved To A Different Date.

Created
Apr 15 at 07:03pm BST

We Are Reconstructing https://alfz.uk

For more details, please visit this page https://status.alfz.uk/incident/544631